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Technologies as governed by United States 
and international copyright laws.
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Trademark Acknowledgements
Pentium is a U.S. registered trademark of 
Intel Corporation. 

Microsoft, Visual Studio, Windows, and MS 
Windows are trademarks of Microsoft Cor-
poration in the United States and or other 
countries.

Warranty

The material contained in this docu-
ment is provided “as is,” and is sub-
ject to changed, without notice, in 
future editions. Further, to the maxi-
mum extent permitted by the applica-
ble law, Keysight disclaims all 
warranties, either express or implied, 
with regard to this manual and any 
information contained herein, includ-
ing but not limited to the implied war-
ranties of merchantability and fitness 
for a particular purpose. Keysight 
shall not be liable for errors or for 
incidental or consequential damages 
in connection with the furnishing, 
use, or performance of this document 
or of any information contained 
herein. Should Keysight and the user 
have a separate written agreement 
with warranty terms covering the 
material in this document that conflict 
with these terms, the warranty terms 
in the separate agreement shall con-
trol.

Technology Licenses 
The hardware and or software described in 
this document are furnished under a license 
and may be used or copied only in accor-
dance with the terms of such license.

Restricted Rights Legend
U.S. Government Restricted Rights.  Soft-
ware and technical data rights granted to 
the federal government include only those 
rights customarily provided to end user cus-
tomers.  Keysight provides this customary 
commercial license in Software and techni-
cal data pursuant to FAR 12.211 (Technical 
Data) and 12.212 (Computer Software) and, 
for the Department of Defense, DFARS 
252.227-7015 (Technical Data - Commercial 
Items) and DFARS 227.7202-3 (Rights in 
Commercial Computer Software or Com-
puter Software Documentation).

Safety Notices

CAUTION

A CAUTION notice denotes a haz-
ard. It calls attention to an operat-
ing procedure, practice, or the likes 
of that, if not correctly performed 
or adhered to, could result in dam-
age to the product or loss of impor-
tant data. Do not proceed beyond a 
CAUTION notice until the indicated 
conditions are fully understood and 
met.

WARNING

A WARNING notice denotes a 
hazard. It calls attention to an 
operating procedure, practice, or 
the likes of that, if not correctly 
performed or adhered to, could 
result in personal injury or death. 
Do not proceed beyond a WARN-
ING notice until the indicated 
conditions are fully understood 
and met.



Safety Symbols

The following symbols on the instrument and in the documentation 
indicate precautions which must be taken to maintain safe operation of 
the instrument.

Direct current (DC)

Alternating current (AC)

Both direct and alternating current

Caution, risk of danger (refer to this manual for specific 
Warning or Caution information)
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Safety Considerations

Read the information below before using this instrument. The descriptions 
and instructions in this manual apply to all the instruments in the Keysight 
modular product family. For more pertinent safety notes, please refer to 
the respective User’s Guide of your modular product.

WARNING • Do not use this device if it is damaged. Before you use the device, 
inspect the casing. Look for cracks or missing plastic.

• Do not operate the device around explosive gas, vapor, or wet 
environments.

• Observe all markings on the device before establishing any 
connection.

• Turn off the device and application system power before 
connecting to the I/O terminals.

• When servicing the device, use only the specified replacement 
parts.

• Do not operate the device with the cover removed or loosened.

• Do not connect any terminal block or cables prior to performing 
the self-test procedure.

• Use only the power adaptor provided by the manufacturer to avoid 
any unexpected hazards.

CAUTION • Electrostatic discharge (ESD) can cause damage to the components 
in the device and accessories. Any cables or wires should be 
connected to the plug-in connectors first and covered with the 
cable casing prior to plugging it into the output connector to prevent 
ESD from occurring.

• If the device is used in a manner not specified by the manufacturer, 
the device protection may be impaired.

• Always use dry cloth to clean the device. Do not use ethyl alcohol or 
any other volatile liquid to clean the device.

• Do not permit any blockage of the ventilation holes of the device.
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Regulatory Markings

The CE mark is a registered trademark
of the European Community. This CE
mark shows that the product complies
with all the relevant European Legal
Directives.

The C-tick mark is a registered 
trademark of the Spectrum 
Management Agency of Australia. This 
signifies compliance with
the Australia EMC Framework
regulations under the terms of the 
Radio Communication Act of 1992.

ICES/NMB-001 indicates that this ISM 
device complies with the Canadian 
ICES-001.
Cet appareil ISM est confomre a la 
norme NMB-001 du Canada.

This instrument complies with the 
WEEE Directive (2002/96/EC) marking 
requirement. This affixed product label 
indicates that you must not discard 
this electrical or electronic product in 
domestic household waste.

The CSA mark is a registered 
trademark of the Canadian Standards 
Association.

This symbol indicates the time period 
during which no hazardous or toxic 
substance elements are expected to 
leak or deteriorate during normal use. 
Forty years is the expected useful life 
of the product.
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Waste Electrical and Electronic Equipment (WEEE) Directive 2002/96/EC

This instrument complies with the WEEE Directive (2002/96/EC) marking 
requirement. This affixed product label indicates that you must not discard 
this electrical or electronic product in domestic household waste. 

Product Category:

With reference to the equipment types in the WEEE directive Annex 1, this 
instrument is classified as a “Monitoring and Control Instrument” product.

The affixed product label is as shown below.

Do not dispose in domestic household waste.

To return this unwanted instrument, contact your nearest Keysight Service 
Center, or visit

www.keysight.com/environment/product

for more information.
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Declaration of Conformity (DoC)

The Declaration of Conformity (DoC) for this instrument is available on the 
Keysight website. You can search the DoC by its product model or 
description at the web address below.

http://www.keysight.com/go/conformity

NOTE If you are unable to search for the respective DoC, please contact your 
local Keysight representative.
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Keysight USB Modular Products and Systems
Overview of the USB Modular Products and Systems
Overview of the USB Modular Products and Systems

The USB modular products and systems are a range of test 
and measurement instruments that offers you the choice and 
flexibility you need to create solutions that are able to 
expand and evolve with the changes of your test 
requirements.

Figure 1 The USB modular products and systems family

Summary of the standard features of a modular product

• Equipped with Hi- Speed USB 2.0 connectivity, capable of 
handling speeds of up to 480 MB/s

• Requires a PC to operate

• Bundled with the Keysight Measurement Manager software 
for immediate measurement start- up

• Supports the Keysight Open program and is compatible 
with a wide range of Application Development 
Environments (ADE)

• Operates as a standalone instrument or as a combined 
module when used with the Keysight U2781A USB 
modular products chassis (able to accommodate up to six 
individual modules)
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Keysight USB Modular Products and Systems
Overview of the USB Modular Products and Systems
Standard purchase items

For the list of standard purchase items of each modular 
product, please refer to the respective User's Guides of your 
modular product. Verify the standard purchase items. If 
anything is missing or damaged, please contact the nearest 
Keysight Sales Office.

Inspection and maintenance

Initial inspection

When you receive your modular product, inspect the unit for 
any obvious damage that may occur during shipment. If any 
damaged is found, contact the nearest Keysight Sales Office 
immediately. Keep the original packaging in case the 
purchased modular product has to be returned to Keysight 
in the future.

General maintenance

1 Power off your device, and remove the power cord and 
I/O cable from your device.

2 Remove your device from the bumper casing.

3 Shake off any dirt that may have accumulated on the 
device.

4 Wipe your device with a dry cloth, and install the bumper 
casing back in place.

NOTE Any repair that is not covered in your modular product manual should only 
be performed by qualified personnel.
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Keysight USB Modular Products and Systems
Installation and Configuration
Installation and Configuration

Follow the step- by- step instructions shown in the following 
flowchart to get started with the preparation and installation 
of your modular product.

Figure 2 Installation and configuration flowchart

NOTE You need to install the IVI-COM driver if you are going to use your USB 
modular product with the Keysight VEE Pro, NI LabVIEW, or Microsoft® 
Visual Studio® software.

“A. Check Your System”

“B. Install the Keysight IO 

“C. Install the Module Driver”

“D. Install the Keysight Measurement Manager”

“E. Connect the Module to Your PC”

“F. Verify Your Module 

“G. Launch the Keysight Measurement Manager”
Keysight USB Modular Products and Systems Quick Start Guide 13



Keysight USB Modular Products and Systems
A. Check Your System
A. Check Your System

Prior to any installation and configuration, please ensure that your PC meets the following 
minimum system requirements.

Requirement Windows® XP operating 
systems

Windows Vista® operating 
systems

Windows 7 operating systems

Operating system Windows XP Service Pack 3 (or 
later)[1]

Windows Vista (32-bit) Service 
Pack 1 and 2[2]

Windows 7 (32-bit and 
64-bit)[3][4]

Processor speed 600 MHz or higher required,  
800 MHz recommended

1 GHz 32-bit (x86) 3 GHz 32-bit (x86)

Memory 256 MB minimum (1 GB or 
greater recommended)

1 GB minimum 2 GB minimum

Hard-disk space 1.5 GB minimum 1.5 GB minimum 1.5 GB minimum

Video Super VGA (800 × 600) 256 
colors or more

Support for DirectX® 9 graphics 
with 128 MB graphics memory 
recommended[5]

Support for DirectX 9 graphics 
with 128 MB graphics memory 
recommended[5]

CD-ROM drive or 
DVD-ROM drive[6]

Required Required Required

Browser Microsoft Internet Explorer® 
5.01 or greater

Microsoft Internet Explorer 7 or 
greater

Microsoft Internet Explorer 7 or 
greater

[1] Supported Windows XP editions — Home or Professional

[2] Supported Windows Vista (32-bit) editions — Home Basic, Home Premium, Business, or Ultimate

[3] Supported Windows 7 (32-bit and 64-bit) editions — Home Basic, Home Premium, Professional, Enterprise, or Ultimate

[4] Keysight Measurement Manger for Windows 7 64-bit support is a 32-bit application running on a WOW64 (Win-
dows-on-Windows 64-bit) emulator.

[5]  Super VGA graphics is supported for Windows Vista and Windows 7.

[6] The type of media provided with the product determines whether a CD-ROM drive or DVD-ROM drive is required.
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Keysight USB Modular Products and Systems
A. Check Your System
Software requirements Availability

Keysight IO Libraries Suite 15.5 Available on the Keysight Automation-Ready CD-ROM

Keysight T&M Toolkit Runtime  
version 2.1

Bundled with the Keysight Measurement Manager software application installer

Keysight T&M Toolkit Redistributable 
Package 2.1 patch

Bundled with the Keysight Measurement Manager software application installer

Microsoft .NET Framework  
version 2.0

Bundled with the Keysight Measurement Manager software application installer
Keysight USB Modular Products and Systems Quick Start Guide 15



Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
B. Install the Keysight IO Libraries Suite

If you have the Keysight IO Libraries Suite 15.5 or higher 
installed on your PC, you may proceed to “C. Install the 
Module Driver” on page 24. If not, please perform this 
procedure to install the Keysight IO Libraries Suite.

1 Verify that your PC meets the minimum system 
requirements. (See “A. Check Your System” on page 14.) 
Close all other applications on your PC, and ready the 
Keysight Automation- Ready CD- ROM.

2 If you are upgrading to the latest version of the Keysight 
IO Libraries Suite from a previous version of the Keysight 
IO Libraries Suite, you must first remove the instruments 
and interfaces listed below before you upgrade your 
software. 

This step is necessary in order for these devices to obtain 
the correct drivers to work with the Keysight IO Libraries 
Suite.

i Disconnect any USB instruments from your PC.

ii Disconnect any Keysight 82357 USB/GPIB interface 
converters from your PC.

iii Disconnect any Keysight E8491 IEEE 1394 PC Link to 
VXI interfaces from your PC.

3 Close all other applications on your PC.

NOTE You must have Administrator privileges to install the Keysight IO Libraries 
Suite Connection Expert.
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
4 Insert the Keysight Automation- Ready CD- ROM with the 
Keysight IO Libraries Suite into the CD- ROM drive of your 
PC. Wait a few seconds for the auto- run window to 
appear.

If the auto- run window does not appear automatically,

• Click Start > Run...

• Type <drive>:autorun\auto.exe, where <drive> is 
your CD- ROM drive letter.

NOTE • If you install a PCI card in your computer at the same time you install 
the Keysight IO Libraries Suite, a possible conflict can occur. The “New 
Hardware Found” dialog for the PCI card must be closed before 
continuing the installation. Otherwise the Keysight IO Libraries Suite 
installation will stop until the PCI card installation is complete.

• If you have NI software installed (such as NI MAX, etc.), then all NI 
services must be stopped prior to installing the Keysight IO Libraries 
Suite.
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
5 When the installation start- up window appears, click the 
“Click here to install now” button once, and wait for the 
InstallShield Wizard to appear.

6 If the IVI Shared Components and IVI VISA COM 
Standard Components are not already installed on your 
PC, the Keysight IO Libraries Suite will install them in the 
default location.

7 When the InstallShield Wizard appears, click Next > to 
begin the Keysight IO Libraries Suite software installation.

8 Read the License Agreement(s). If you accept the terms, 
click the radio button labeled “I accept the terms of the 
license agreement”, and then click Next > to continue.

NOTE Every Keysight IO Libraries Suite installation is a “Full installation”

In past versions of the Keysight IO Libraries Suite, an option to install 
Keysight IO Libraries Suite as either as a Full version or a Runtime version 
was provided. Beginning with the Keysight IO Libraries Suite 14.0, the 
installation process provides a Full installation for all users (i.e., there is no 
longer a Runtime installation option). This means that every installation 
now includes the development components of the Keysight IO Libraries 
Suite software, which allow you to develop your own I/O programs. If you 
wish to minimize the size of the installed software, select Custom 
installation; when you get to the Select Features dialog, do not select the 
manuals and the sample programs.

NOTE You also have the opportunity to watch a two-minute video how easy it is 
to install, set-up, and configure your interfaces and instruments using the 
Keysight IO Libraries Suite 15.

NOTE The IVI Shared Components and IVI VISA COM Standard Components are 
installed in default folders. However, if you need to install the IVI 
Components in a unique location refer to “Custom Installation of IVI 
Shared Components” in the Keysight IO Libraries Suite Connectivity Guide.
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
9 When the InstallShield Wizard Setup Type dialog appears, 
as shown, select Typical or Custom, then click Next >.

The Typical setup installs the recommended features for 
your configuration in standard locations on your PC. In a 
Typical setup, if another vendor’s VISA software is 
already installed on this PC, Keysight VISA is installed as 
secondary. If no other vendor’s VISA software is found on 
this PC, Keysight VISA is installed as primary. (See also 
“Using Keysight VISA in Side- by- Side Mode” in the 
Keysight IO Libraries Suite Connectivity Guide.)

10 If you chose the Custom setup and you do not have 
another vendor’s VISA implementation installed on your 
PC, then you will see the dialog below, which asks 
whether you want to install Keysight VISA as the primary 
VISA.

NOTE • If you accept the “Typical Installation”, click Next > and proceed to 
step 13.

• If you chose the “Custom Installation” radio button, click Next > and 
proceed with step 10 below.
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
If you have another vendor’s VISA installed, you will see a 
similar dialog, but the check box will not be selected, 
indicating that the default is to install Keysight VISA as 
secondary.

For details on this topic, see “Using Keysight VISA in 
Side- by- Side Mode” in the Keysight IO Libraries Suite 
Connectivity Guide.

11 If you chose a Custom setup, the next dialog shows the 
location of the:

• Keysight IO Libraries Suite destination folder

• Keysight VISA destination folder, and

• IVI components destination folder

The VISA and IVI destinations are greyed out. They are 
for information only. In order to change them, you 
must follow the instructions in “Custom Install the IVI 
Shared Components” in the Keysight IO Libraries Suite 
Connectivity Guide.

12 If you chose a Custom setup, you will now see the Select 
Features dialog.

i Click on any feature in the list to see the feature 
description and the space requirements for the selected 
set of features. It is recommended that you install the 
manuals and sample programs if you plan to program 
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
with the Keysight IO Libraries Suite; however, you may 
omit them to save space.

ii Select the check box for each feature to be installed. 
Clear the check box for each feature to omit. When you 
are done selecting features, click Next >.

13 The Start Copying Files dialog appears; click Install to 
begin copying files.

If the Microsoft .NET Framework version 2.0 has not 
previously been installed on your PC, Keysight IO 
Libraries Suite will install them; this may take up to ten 
minutes. The Microsoft .NET Framework provides 
necessary infrastructure for the Keysight IO Libraries 
Suite utilities, as well as for .NET programming tools and 
many other applications. You will only need to install the 
.NET Framework once, even if you remove and reinstall or 
upgrade your Keysight IO Libraries Suite.

14 After the files have been copied, you may see a dialog 
asking you to restart your PC. This occurs only if you 
have certain I/O hardware configurations. If you choose 
not to reboot at this time, you should reboot before 
running Connection Expert.
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
15 When the InstallShield Wizard Completed dialog appears 
indicating that Keysight IO Libraries Suite was 
successfully installed:

i Click Finish to close the window.

ii Or click on one of the product/solution links for 
information on other Keysight solutions.

16 Click the IO control icon ( ) in lower right Windows 
Notification area to run Keysight IO Libraries Suite.

17 If you are installing Keysight IO Libraries Suite along with 
another instrument, interface, or software package such 
as Keysight VEE, there may be another CD with additional 
software (drivers, sample programs, and so on). If you 
want to install this additional software,

• Insert the CD into the CD- ROM drive on your PC.

• Follow the instructions that came with the CD or the 
hardware or software product.

18 Re- connect any USB instruments or E8491 IEEE- 1394 
FireWire to VXI interfaces that you may have 
disconnected in step 2. Install any new hardware.

19 If Connection Expert is already running, click Refresh All 
to identify any hardware you have just installed or 
re- connected.

20 If Connection Expert is not already running, run it now 
to verify your I/O configuration: In the Windows 
Notification area, click the IO icon ( ), and then click 
Keysight Connection Expert.

i Locate your interfaces and instruments in the Explorer 
Pane. Click on them to see their properties (displayed 
in the right- hand pane). Observe their state, also 
displayed in the right- hand pane: if communication to 
the interface or instrument has been successfully 
established, it will be in the Verified state, which is 
denoted by a green check mark.

ii Change the default I/O configuration (if necessary) by 
clicking Change Properties... in the property pane of the 
interface or instrument you wish to configure.
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Keysight USB Modular Products and Systems
B. Install the Keysight IO Libraries Suite
iii If you would like to test your connections manually, 
select your instrument, and then right- click and choose 
Send Commands To This Instrument.

If possible, you should always use the current version of the 
Keysight IO Libraries Suite. This version supports the newest 
interfaces and operating systems, and has the most 
advanced features. For more information on the Keysight IO 
Libraries Suite, go to www.keysight.com/find/iosuite.

NOTE If you plan to program your GPIB instruments using the Keysight 488 API, 
or to run NI-488.2-compatible programs with Keysight interface hardware 
(such as GPIB cards), you may need to enable the Keysight 488 library. To 
do this, click Tools > Keysight 488..., then select the check box labeled 
“Enable Keysight GPIB cards for 488 programs”.

NOTE If you encounter problems while installing the Keysight IO Libraries Suite, 
see the “Installation Troubleshooting” section in the Keysight IO Libraries 
Suite Connectivity Guide.

Vista Installation with UAC Disabled

If you experience problems installing Keysight IO Libraries Suite on a 
system with the Windows Vista operating system, you may have the User 
Account Control (UAC) enabled. Typically, you may get an error message 
stating that a directory name is invalid. UAC must be disabled prior to 
installing Keysight IO Libraries Suite.
Keysight USB Modular Products and Systems Quick Start Guide 23



Keysight USB Modular Products and Systems
C. Install the Module Driver
C. Install the Module Driver

1 Verify that your PC meets the minimum system 
requirements. (See “A. Check Your System” on page 14.) 
Close all other applications on your PC, and ready the 
Keysight USB Modular Products and Systems Product 
Reference DVD- ROM.

2 Insert the Keysight USB Modular Products and Systems 
Product Reference DVD- ROM with into the DVD- ROM 
drive of your PC. Wait a few seconds for the auto- run 
window to appear.

If the auto- run window does not appear automatically,

• Click Start > Run...

• Type <drive>:\Autorun.exe, where <Drive> is your 
DVD- ROM drive letter.

3 When the installation start- up window appears, click the 
“Hardware Driver” button once, and wait for the 
InstallShield Wizard to appear.

NOTE • Ensure that your modular product is disconnected from your PC before 
installing the driver.

• Verify that the Keysight IO Libraries Suite version 15.5 or higher is 
installed before proceeding. See “B. Install the Keysight IO Libraries 
Suite” on page 16 for more information on the Keysight IO Libraries 
Suite installation procedure.
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C. Install the Module Driver
4 When the InstallShield Wizard appears, click Next > to 
begin the module driver(s) installation.

5 Read the License Agreement(s). If you accept the terms, 
click the radio button labeled “I accept the terms of the 
license agreement”, and then click Next > to continue.

6 Read the Readme Information carefully. Ensure that all 
USB modular product devices are disconnected from your 
PC. Click Next > to continue.

7 When the InstallShield Wizard Setup Type dialog appears, 
as shown, select Typical or Custom, and then click Next >.
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Keysight USB Modular Products and Systems
C. Install the Module Driver
The Typical setup installs the recommended features for 
your configuration in standard locations on your PC.

8 If you chose a Custom setup, you will now see the 
Custom Setup dialog.

i Click on any feature in the list to see the feature 
description and the space requirements for the selected 
set of features.

ii Clear each feature to omit by selecting “This feature 
will not be available” option. When you are done 
selecting features, click Next >.

9 The Ready to Install the Program dialog appears; click 
Install to begin copying files.

10 When the InstallShield Wizard Completed dialog appears 
indicating that the module driver(s) was successfully 
installed, click Finish to close the window.

NOTE • If you accept the “Typical Installation”, click Next and proceed to 
step 9.

• If you chose the “Custom Installation” radio button, click Next and 
proceed with step 8 below.
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D. Install the Keysight Measurement Manager
D. Install the Keysight Measurement Manager

1 If you have performed the module driver installation in 
“C. Install the Module Driver” on page 24 and the 
Keysight Modular Products Installation Menu is still open, 
you may proceed to step 4. Otherwise, proceed to the 
next step.

2 Verify that your PC meets the minimum system 
requirements. (See “A. Check Your System” on page 14.) 
Close all other applications on your PC, and ready the 
Keysight USB Modular Products and Systems Product 
Reference DVD- ROM.

3 Insert the Keysight USB Modular Products and Systems 
Product Reference DVD- ROM into the DVD- ROM drive of 
your PC. Wait a few seconds for the auto- run window to 
appear.

If the auto- run window does not appear automatically,

• Click Start > Run...

• Type <drive>:\Autorun.exe, where <drive> is your 
DVD- ROM drive letter.

4 When the installation start- up window appears, click the 
“Measurement Manager” button once, and wait for the 
InstallShield Wizard to appear.

NOTE Verify that the Keysight IO Libraries Suite version 15.5 or higher is installed 
before proceeding. See “B. Install the Keysight IO Libraries Suite” on 
page 16 for more information on the Keysight IO Libraries Suite installation 
procedure.
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Keysight USB Modular Products and Systems
D. Install the Keysight Measurement Manager
5 If you do not have any of the prerequisites installed, the 
InstallShield Wizard Software Prerequisite dialog will 
appear. Click OK to begin the installation of the listed 
missing prerequisites.

Follow the on- screen instructions to install the listed 
missing prerequisites. Once the above installation has 
completed, installation of the Measurement Manager 
software will proceed as normal.

6 When the InstallShield Wizard appears, click Next > to 
begin the Measurement Manager installation.

7 Read the License Agreement(s). If you accept the terms, 
click the radio button labeled “I accept the terms of the 
license agreement”, and then click Next > to continue.

8 Fill in the Customer Information Form accordingly, and 
click Next.

9 Click Next to install to the specified folder, or click Change 
to install to a different folder.

10 The Ready to Install the Program dialog appears; click 
Install to begin copying files.

NOTE Disconnect all modular products from your PC before you proceed.
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11 When the InstallShield Wizard Completed dialog appears 
indicating that the module driver(s) was successfully 
installed, click Finish to close the window. A shortcut to 
this software will be created on your desktop.

NOTE Licensed Materials Usage

Using the licensed materials indicates your acceptance of the license 
terms. If you do not agree to all of these terms, you may return any 
unopened licensed material for a full refund. If the licensed materials are 
bundled or pre-loaded with another product, you may return the entire 
unused product for a full refund.
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E. Connect the Module to Your PC

1 After all the software and driver installations have 
completed, connect the power cord to the AC/DC power 
adaptor. The AC/DC power adaptor requirements are 100 
to 240 VAC, 50/60 Hz, with an output voltage of +12 VDC.

2 Insert the DC output plug from the AC/DC power adaptor 
to the power jack on the rear panel of the modular 
product.

3 Connect the modular product to any USB port on your PC 
with the bundled USB cable.

4 Your PC will automatically detect the connected unit, and 
the Found New Hardware Wizard window will appear. 
Select the “Yes, this time only” radio button, and click 
Next to proceed.

5 Select Install the software automatically (Recommended) 
and click Next.

6 A warning message will appear on the Hardware 
Installation window.

Read the warning carefully, and click Continue Anyway to 
proceed with the installation of the modular product.

NOTE • Ensure that the Measurement Manager is installed before proceeding. 
See “D. Install the Keysight Measurement Manager” on page 27 for 
more information on the Measurement Manager installation procedure.

• The figures shown below are for illustration purposes only and may 
appear different on your PC depending on your PC’s operating system 
and the type of modular product(s) connected.
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7 When the Found New Hardware Wizard Completed dialog 
appears indicating that the device software was 
successfully installed, click Finish to close the window.

8 The Assign USB device alias window will appear. Each 
time the modular product is plugged in, this dialog will 
appear. To disable this dialog, select the “Never show this 
dialog” option in the Show this dialog panel, and click OK.

NOTE If you do not wish to receive similar warning messages in the future, 
follow the instructions below:

1 Click Start > Control Panel, and double-click the System icon.

2 Select the Hardware tab, and click Driver Signing on the Drivers panel. 
The Driver Signing Options dialog will appear.

3 Select the “Ignore” radio button to disable the warning message.
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9 For modules other than the U2300A Series, U2500A 
Series, U2600A Series, and the U2781A, the system will 
perform a firmware version check on your connected 
module.

i If the module firmware version is the same as the 
installed version on the PC, a firmware download will 
not be performed. The modular product is now ready 
for use.

ii If the module firmware version differs from the 
installed version on the PC, the following message box 
will appear. The model number and firmware versions 
shown on the message box may vary depending on the 
module connected to your PC.

iii Click Yes to begin the firmware download. The 
following message box will appear indicating that the 
download in progress. The model number shown on the 
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message box may vary depending on the module 
connected to your PC.

10 Your modular product is ready for use once the firmware 
download and upgrade has been completed.

CAUTION Do not remove the USB and power connection until the firmware 
download has been completed. Interrupting the firmware download 
process may result in a device failure.
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F. Verify Your Module Connection

The Connection Expert is one of the utilities in the Keysight 
IO Libraries Suite. The Connection Expert configures the 
connected instrument(s) and enables communication. It is 
able to automatically detect any modular product plugged 
into the PC.

1 Apply power to the PC and to the installed modular 
product(s).

2 If the Connection Expert is already running, click Refresh 
All to identify any hardware you have just installed or 
re- connected.

3 If the Connection Expert is not already running, run it 
now to verify your I/O configuration(s): In the Windows 
Notification area, click the IO icon ( ), and then click 
Keysight Connection Expert.

4 When the main screen appears, you will see a map of the 
system connections in the Instrument I/O on this PC pane 
(also called the “Explorer Pane”).

NOTE The figures shown below are for illustration purposes only and may appear 
different on your PC depending on your PC’s operating system and the type 
of modular product(s) connected.
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5 The detected modular product will be visible on the 
Instrument IO the Explorer Pane.

When you select a particular instrument in the Explorer 
Pane, you will see the parameters of the instrument in 
the Properties Pane on the right — such as the model 
number of the product, serial number, VISA address, GPIB 
address, and firmware revisions.

The green check mark icon at the top signifies that a 
listener check and identification (*IDN) query were 
performed automatically.
Keysight USB Modular Products and Systems Quick Start Guide 35



Keysight USB Modular Products and Systems
F. Verify Your Module Connection
6 We will use the Interactive IO to quickly verify the 
connectivity to your instrument. The Interactive IO is a 
software utility that allows you to interact with an 
instrument by sending commands to the instrument and 
seeing the instrument’s responses. 

To start the Interactive IO from within Connection Expert, 
click Tools > Interactive IO from the Connection Expert 
menu bar, or right- click on the modular product in the 
Explorer Pane. A context menu will appear. Select Send 
Commands To This Instrument.

7 The Interactive IO dialog will appear. Click Send & Read to 
send the *IDN? default command. The instrument 
response should appear in the Instrument Session History 
panel.

8 If the Connection Expert can successfully communicate 
with your modular product, this indicates that the 
instrument is installed correctly.
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G. Launch the Keysight Measurement Manager

1 Double- click the Measurement Manager software icon on 
your desktop or go to Start > All Programs > Keysight > 
Modular Products > Keysight Measurement Manager to launch 
the software.

2 The Measurement Manager welcome screen will appear.

3 The Select USB Device dialog will appear displaying the 
connected modular product. To start the application, 
select the modular product and click OK to establish a 
connection. The model number shown on the Available 
USB Devices pane may vary depending on the module(s) 
connected to your PC.

4 The Measurement Manager will launch the appropriate 
measurement application depending on the USB modular 

NOTE The IO Control will launch automatically when you start your PC

Launching the Measurement Manager without running the IO Control will 
cause failure in communicating with any USB modular product connected 
to your PC. To run the IO Control, go to Start > All Programs > Keysight IO 
Libraries Suite > Utilities > IO Control.

NOTE The figures shown below are for illustration purposes only and may appear 
different on your PC depending on your PC’s operating system and the type 
of modular product(s) connected.
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product selected. See the Keysight Measurement Manager 
Help File for further information pertaining to your 
modular product application software.
38 Keysight USB Modular Products and Systems Quick Start Guide



Keysight USB Modular Products and Systems
USB Modular Products Chassis
USB Modular Products Chassis

The Keysight U2781A USB modular products chassis is a 
portable chassis that is able to house up to six USB modular 
devices. It is equipped with USB plug- and- play connectivity 
and is compliant to the USBTMC- USB488.2 standards[1], 
allowing it to work seamlessly with the Measurement 
Manager software. 

Purchasing a U2781A chassis enables you to add 
synchronization capability between modules via a star trigger 
bus. For more details on the U2781A chassis, refer to the 
Keysight U2781A USB Modular Products Chassis User's Guide.

Figure 3 The U2781A chassis connected to a PC

Chassis installation

The L- Mount kit is to be installed on your module. The 
following instructions describe the simple procedure of 
installing the L- Mount kit and your module into the U2781A 
chassis.

1 Unpack the L- Mount kit from the packaging.

2 Remove your module from the bumper casing.

3 Using a Phillips screwdriver, fasten the L- Mount kit to 
your module.

[1] Compatible with Microsoft Windows operating systems only.
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4 Insert your module into the U2781A chassis with the 
55- pin backplane connector positioned at the bottom of 
the module. See the “55- pin backplane connector pin 
configuration” for more information.

5 Once you have slotted in the module, tighten the screws 
on the L- Mount kit to secure the connection to the 
chassis.

55-pin backplane connector pin configuration

The 55- pin backplane connector is used when your module 
is slotted into the U2781A chassis. Refer to Table 1 for the 
SSI connector pin descriptions.

Figure 4 55-pin backplane connector pin configuration

GND GND GND GND GND GND GND GND GND GND GND F

NC NC NC NC NC NC NC NC VBUS GND USB_D– E

GND TRIG3 GND TRIG2 GND TRIG1 GND TRIG0 GND GND USB_D+ D

TRIG4 GND TRIG5 GND TRIG6 GND TRIG7 GND +12 V +12 V GND C

nBPUB CLK10M GND STAR_TRIG GA2 GA1 GA0 NC +12 V +12 V +12 V B

NC NC NC NC NC NC NC NC +12 V +12 V +12 V A

11 10 9 8 7 6 5 4 3 2 1
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Table 1 SSI connector pin description

SSI timing signal Functionality

GND Ground

NC Not connected

VBUS USB bus power sensing input

USB_D+, USB_D– USB differential pair

TRIG0 ~ TRIG7 Trigger bus

+12 V +12 V power with 4 A current

nBPUB USB backplane input detect

CLK10M 10 MHz clock source

STAR_TRIG Star trigger

GA0, GA1, GA2 Geographical address pin
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Windows 7

When installing the Keysight USB Modular Instrument driver 
on a computer running Windows 7, you may experience the 
following issues:

• Driver installation failure.

• Computer- to- hardware connection failure after a 
successful driver installation.

If these issues arise, refer to the steps below:

1 Compare the file size of the downloaded setup file with 
the file size as stated on the Web. If the size of the 
downloaded setup file is smaller, this may indicate that 
the setup file is corrupted. In this case, download the 
setup file again and cross- check the file size before 
proceeding with installation.

2 Ensure that you are logged into your computer with 
Administrator privileges.

3 Set the User Account Control (UAC) to the lowest security 
level to prevent the operating system from interfering 
with the installation program.

4 Ensure that your computer is running the latest version 
of IO Libraries Suite (version 16.2 or greater).

5 Reinstall the latest version of AMM with prerequisites 
(version 2.2.1.0 or greater).

If you are still unable to establish a successful connection 
after following the steps above, please contact your nearest 
Keysight Support toll- free number.
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Software drivers

Software components and applications for IVI- COM drivers 
and MATLAB DAQ Adaptors are provided with the Keysight 
USB Modular Products and Systems Product Reference 
DVD- ROM.

The IVI- COM drivers are used to program the test 
instruments in an IVI- COM environment, while the MATLAB 
DAQ Adaptor allows the data acquisition modular products 
(U2300A Series, U2500A Series, and U2600A Series) to be 
controlled in a MathWorks environment.

To install the IVI-COM drivers

Select Software Driver > IVI-COM on the Keysight Modular 
Products Installation Menu, and select the check box for 
each product series to be installed. Clear the check box for 
each product series to omit.

Figure 5 Keysight IVI-COM Driver Installation Menu

NOTE • The IVI Shared Components must also be installed prior to installing 
the IVI-COM driver. Find the IVI Shared Components at the IVI website 
here: www.ivifoundation.org.

• If needed, the IVI-COM driver may also be downloaded from this site: 
www.keysight.com/find/ivi-com.
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To install the MATLAB DAQ Adaptor

Select Software Driver > MATLAB on the Keysight Modular 
Products Installation Menu, and select the check box for 
each product series to be installed. Clear the check box for 
each product series to omit.

Figure 6 Keysight MATLAB DAQ Adaptor Installation Menu

NOTE In order to use these devices with MATLAB, you need to install the 
MATLAB and Keysight software components and applications, connect 
the DAQ modular product, and install the respective drivers. A MATLAB 
example is provided at: 

• www.keysight.com/find/matlab_u2300a for the U2300A Series DAQ

• www.keysight.com/find/matlab_u2500a for the U2500A Series DAQ

• www.keysight.com/find/matlab_u2600a for the U2600A Series DIO
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Sample codes

Sample codes for the Keysight VEE, LabVIEW, and Microsoft 
(C#, C++, VB7, and VB6) software platforms are provided to 
help you get started with your modular product.

To view the sample codes

Select Sample Codes on the Keysight Modular Products 
Installation Menu, and choose the preferred programming 
language type as shown in the following figure.

Figure 7 Viewing the sample codes

NOTE • For more information on how to install the MATLAB DAQ Adaptor, see 
the respective product series’ Using the USB Multifunction Data 
Acquisition Devices with MATLAB Software Quick Start Guides.

• You can install the MATLAB software directly from the MATLAB 
installation DVD-ROM or from the MathWorks website. If you do not 
already have the MATLAB or MATLAB’s Data Acquisition Toolbox 
software, you can request a trial version at: 
www.mathworks.com/keysight/daq/tryit.html
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Command logger and code converter

The Measurement Manager offers you quick and easy 
configuration and control without the need for programming 
work. To further simplify your work, you can use the 
provided Command Logger function that logs the 
configuration commands and easily convert them to snippets 
of Keysight VEE, Microsoft Visual Basic, Microsoft Visual C#, 
or Microsoft Visual C++ codes.

• To launch the Command Logger function: launch the 
Measurement Manager, and go to Tools > Command Logger....
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• To convert the logged commands in to other languages: 
from the Command Logger window, click File > Convert 
Command File.

NOTE For more information on how to use the Command Logger application, 
refer to the Keysight Measurement Manager Help File.
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Activate your device license

If you have purchased a with an Option, you are required to 
activate the device license before you can use its additional 
feature(s). You may activate the device license through the 
Software Licensing application in the Measurement Manager.

Figure 8 Software Licensing application

NOTE • You do not need to perform this procedure if you have not purchased a 
modular product with an Option. Please refer to the respective User's 
Guide of your modular product to find out more about the Option(s) 
available with your modular product.

• If you do not wish to install the Measurement Manager, you will need 
to launch the Software Licensing stand-alone installer. Select Software 
Licensing on the Keysight Modular Products Installation Menu, and 
follow the instruction on-screen.
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• To activate your device license, launch the Measurement 
Manager and go to Tools > License Panel.

• To verify your device license(s) from the Software 
Licensing window, click Verify License > Update License.

NOTE You will require a valid device license key (*.lic). If you do not have a device 
license key, you will need to redeem your device license key at 
www.keysight.com/find/softwarelicense. Follow the on-screen 
instructions to redeem a valid license key for your device.

NOTE For more information on how to use the Software Licensing application, 
refer to the Keysight Measurement Manager Help File.
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Contact us
To obtain service, warranty, or technical 
assistance, contact us at the following 
phone or fax numbers:

United States:

(tel) 800 829 4444 (fax) 800 829 4433

Canada:

(tel) 877 894 4414 (fax) 800 746 4866

China:

(tel) 800 810 0189 (fax) 800 820 2816

Europe:

(tel) 31 20 547 2111

Japan:

(tel) (81) 426 56 7832 (fax) (81) 426 56 7840

Korea:

(tel) (080) 769 0800 (fax) (080) 769 0900

Latin America:

(tel) (305) 269 7500

Taiwan:

(tel) 0800 047 866 (fax) 0800 286 331

Other Asia Pacific Countries:

(tel) (65) 6375 8100 (fax) (65) 6755 0042

Or visit Keysight World Wide Web at:
www.keysight.com/find/assist

Product specifications and descriptions in 
this document are subject to change 
without notice. Always refer to the 
Keysight website for the latest revision.

www.keysight.com


This information is subject to change without notice.
© Keysight Technologies 2008 - 2014

Edition 5, December 2014

*U2702-90001*
U2702-90001

www.keysight.com


	Quick Start Guide
	Keysight USB Modular Products and Systems
	Table of Contents
	Overview of the USB Modular Products and Systems
	Standard purchase items
	Inspection and maintenance

	Installation and Configuration
	A. Check Your System
	B. Install the Keysight IO Libraries Suite
	C. Install the Module Driver
	D. Install the Keysight Measurement Manager
	E. Connect the Module to Your PC
	F. Verify Your Module Connection
	G. Launch the Keysight Measurement Manager
	USB Modular Products Chassis
	Chassis installation
	55-pin backplane connector pin configuration

	Additional Information
	Windows 7
	Software drivers
	Sample codes
	Command logger and code converter
	Activate your device license


